Fiji with Java 6 on Mac OSX El Capitan

Update (15.01.2016): The 3D Viewer now works with Java 8. Please use the “3D” update site.

Fiji 3D Viewer crashes with Java 8

While previous Mac OSX versions had there own versions of Java, the new OSX 10.11 El Capitan guide the user to the Oracle site to install the newest Java JDK 8.

Users of Fiji or ImageJ may run into problems if they want to use 3D visualization such as the 3D Viewer. This is a known bug of the 3D viewer in combination with Java JDK 8 and should be fixed with a future release.

In the meantime, it is advised to use Java JDK 6 instead of 8. This sounds easy enough.

Install Java 6 on Mac OSX El Capitan

Oracle keeps an archive from you can download which older versions of Java. However, you will notice that none of these are suitable for Mac OSX!

Luckily, I found that Apple itself provide a legacy version of Java for 10.11 El Capitan can be downloaded here.

With this legacy version of Java, I got Fiji’s 3D Viewer as well as VolumeViewer running smoothly on El Capitan.